Get in touch
Back
Downtime

Maintenance Window Commenced

Started 27 Aug at 10:55pm BST, resolved 27 Aug at 11:40pm BST.

TimeKeeper Web Portal TimeKeeper API
Resolved

Maintenance window completed as of 11.40pm BST. Clocking in and out was unavailable from 11PM to 11.27PM BST.

The maintenance is now complete.

Posted 27 Aug at 11:40pm BST.
Created

TimeKeeper is being taken offline for a maintenance window as advised to customers. The maintenance window is from 11PM BST to 6AM BST. We will update on completion.

Posted 27 Aug at 10:55pm BST.