
Infrastructure Upgrade Maintenance
Completed 21 Dec at 10:55pm GMT.
Completed
Maintenance is complete as of 10.54pm. If you are experiencing any issues, please contact support@timekeeper.co.uk.
Thank you for your understanding during this upgrade.
Updated
The TimeKeeper platform is serving requests again.
Updated
Currently the TimeKeeper platform is not serving requests as the maintenance is ongoing.
Updated
TimeKeeper's Scheduled Maintenance has commenced. Accessing the platform may be interrupted during this period, including clocking in and out. We will post updates on the progress of the maintenance.

Started
TimeKeeper is upgrading our infrastructure to enhance the speed and reliability of the platform as we continue to grow.
During this upgrade (Saturday 21st December 10pm to 6am GMT), the web and mobile applications may experience downtime, and clocking in/out may be temporarily unavailable. We anticipate that the upgrade will be completed before the end of the maintenance window.
We apologise for any inconvenience and appreciate your understanding as we aim to schedule this upgrade at a time that minimises disruption for our customers.