Get in touch
Back
Resolved

Degraded Availability Across Services

Started 26 Nov at 08:00am GMT.

TimeKeeper Web Portal TimeKeeper API
Created

TimeKeeper is currently experiencing an issue with our infrastructure provider who are having momentary blackouts in the EU. This is causing issues for some employees clocking in as well as accessing the web dashboard. We are working on right now.

Posted 26 Nov at 08:00am GMT.