Get in touch
Back
Maintenance

TimeKeeper Scheduled Database Maintenance

Completed 7 Mar at 11:08pm GMT.

TimeKeeper Web Portal TimeKeeper API
Completed

Maintenance is now complete and everything is operating normally. If you experience any issues, please contact us at support@timekeeper.co.uk for assistance.

You may notice the platform is slightly slower initially as it rebuilds its access patterns over the coming days, after which you should see improved performance.

This upgrade also ensures our database is running on a modern, supported version with the latest security fixes and patches, in line with best practices.

Thank you for your patience during this upgrade.

Posted 7 Mar at 11:08pm GMT.
Updated

Some previous database connections were cached causing some issues for some users. A fresh deploy helped resolve this as of 10.37pm.

Posted 7 Mar at 10:40pm GMT.
Updated

Database upgrade completed 22.16pm. Running checks.

Posted 7 Mar at 10:19pm GMT.
Updated

Database upgrade initiated at 22.15pm Saturday 7th March 2026 GMT.

Posted 7 Mar at 10:15pm GMT.
Started

TimeKeeper will be carrying out scheduled database maintenance on Saturday, 7 March 2026, between 10:00 PM and Sunday, 8 March 2026 6:00 AM (GMT)

This is a maintenance window, and while we expect any disruption to be minimal and very brief (likely under one minute), the web and mobile apps may be temporarily unavailable. Clocking in and out could also be momentarily affected.

Thank you for your understanding.

Posted 7 Mar at 10:00pm GMT.